The issue preventing assigned towing equipment from being dispatched from reservations has been resolved.
Service was restored by rolling back a recent change. Our teams will continue investigating the cause.
If you experience any lingering issues, please contact Support at 606901 or 800-223-6217. You can also chat with Support using the life preserver icon in the bottom-left corner of ESL. Thank you for your patience. -------------------------------------------------------------------------------------------------
Posted Sep 09, 2026 - 16:12 MST
Monitoring
The issue preventing assigned towing equipment from being dispatched from reservations has been resolved.
Service was restored by rolling back a recent change. Our teams will continue investigating the cause.
If you experience any lingering issues, please contact Support at 606901 or 800-223-6217. You can also chat with Support using the life preserver icon in the bottom-left corner of ESL. Thank you for your patience. -------------------------------------------------------------------------------------------------
Posted Sep 09, 2026 - 15:58 MST
Investigating
Some users are experiencing issues when Dispatching Towing Equipment that is on a reservation. The Equipment shows as unavailable for selection during the dispatch process.
If you are encountering this issue, please try Dispatching the Equipment as a walk-in instead.
Steps for Walk-In Rental: ESL>Equipment> Walk-In Rental.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------