HSL Operational

Incident Report for U-Haul System

Resolved

The cause was related to a back-end system that impacted HSL functionality in POS. Services have been restored, and HSL should now be functioning normally.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Jul 15, 2026 - 13:49 MST

Monitoring

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Jul 15, 2026 - 13:29 MST

Investigating

In the meantime, you can search the contract number using the HSL Search Bar at upper-right side to access the service invoice.

Our teams are working to resolve the issue as quickly as possible.

For further assistance, call Support at 606901 or 800-223-6217, or use the Life Preserver chat icon in the bottom-left corner of the ESL.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Jul 15, 2026 - 12:26 MST
This incident affected: Point of Sale (Hitch Scheduling Log (HSL)).