Hitch Reservations are now Operating Properly

Incident Report for U-Haul System

Resolved

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 03, 2026 - 08:01 MST

Monitoring

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 03, 2026 - 07:46 MST

Investigating

We are currently experiencing issues with Hitch functionality/Loading.

Please contact POS Support at VOIP extension 606901 or 800-223-6217 for assistance.

For additional support, you may also initiate a chat using the Life Preserver icon located in the bottom left corner of the ESL.
We appreciate your patience while we work to resolve this issue.
-------------------------------------------------------------------------------------------------
Posted Mar 03, 2026 - 06:37 MST
This incident affected: Point of Sale (Hitch Scheduling Log (HSL)).