Uhaul.com site is back up and running

Incident Report for U-Haul System

Resolved

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted May 20, 2025 - 16:14 MST

Monitoring

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted May 20, 2025 - 16:01 MST

Investigating

We are currently investigating this problem and will provide further updates when available.
Posted May 20, 2025 - 15:48 MST
This incident affected: uhaul.com and Truck Share (uhaul.com).