Resolved - Multiple Applications down

Incident Report for U-Haul System

Resolved

A fix has been implemented, and all applications are back up and running.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
------------------------------------------------------------------------------------------------
Posted Feb 07, 2025 - 09:28 MST

Monitoring

A fix has been implemented, and all applications are back up and running.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
------------------------------------------------------------------------------------------------
Posted Feb 07, 2025 - 09:17 MST

Update

To continue business operations, please use backupPOS - backuppos.uhaul.net

Reminder To Log-In:

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 07, 2025 - 08:59 MST

Investigating

To continue business operations, please use backupPOS - backuppos.uhaul.net

Reminder To Log-In:

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 07, 2025 - 08:30 MST
This incident affected: Point of Sale (POS), Rates and Distribution (Web AMT), and uhaul.net (Contract Lookup).