Drivers License Verification and Media Services are Fully Restored

Incident Report for U-Haul System

Resolved

The issue was caused by an API process that generated an unexpectedly large number of requests and created excessive demand on a critical service. We have removed the operation that caused the requests and the system has returned to normal.

If you experience any lingering issues, please contact support at VOIP extension 606901, or call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jul 25, 2026 - 16:29 MST

Monitoring

The issue was caused by an API process that generated an unexpectedly large number of requests and created excessive demand on a critical service. We have removed the operation that caused the requests and the system has returned to normal.

If you experience any lingering issues, please contact support at VOIP extension 606901, or call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jul 25, 2026 - 16:19 MST

Update

We are investigating reports of driver license verification errors and delays during the dispatch process.
This issue may also impact other media services, resulting in intermittent delays or errors.

Our teams are actively investigating the issue and working to identify the root cause.
Additional updates will be provided as more information becomes available.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jul 25, 2026 - 11:47 MST

Investigating

We are investigating reports of driver license verification errors and delays during the dispatch process.
This issue may also impact other media services, resulting in intermittent delays or errors.

Our teams are actively investigating the issue and working to identify the root cause.
Additional updates will be provided as more information becomes available.

If you continue to experience issues, please use BackupPOS to continue business operations until the issue is resolved.
backuppos.uhaul.net

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #


Please do not upload Backup contracts until the system is fully operational.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jul 25, 2026 - 09:13 MST
This incident affected: Point of Sale (POS) and uhaul.com and Truck Share (Live Verification, Truck Share).