Admin VPN Duo Failure

Incident Report for U-Haul System

Resolved

The VIP (fpr06.amerco.com) has been restored for AdminVPN, please contact the network support team if you continue to have issues with your VPN connection at network_support@uhaul.com or 606911, option 6.
Posted Nov 20, 2025 - 12:31 MST

Identified

We have identified an issue with one of our VPN appliances, causing intermittent failures. The workaround for now will be to target fpr16.amerco.com instead of fpr06. Working to restore the pair.
Posted Nov 20, 2025 - 11:14 MST

Investigating

Network team is currently investigating an issue with Duo MFA impacting Admin VPN users.

This is not impacting field VPN or center operations, only administrators.

We will post more information once we identify the issue or have a workaround.
Posted Nov 20, 2025 - 11:08 MST
This incident affected: Network (VPN).