U-Haul Life Offline
Incident Report for U-Haul System
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 20:34 MST
Investigating
We are currently investigating an outage for the U-Haul Life / Workday website, this is impacting all users.
Posted Jul 15, 2024 - 16:41 MST
This incident affected: Workday / U-Haul life.