Azure Services Back Up

Incident Report for U-Haul System

Resolved

All applications are back up and operational
--------------------------------------------------------------------------------------------------
Posted Oct 29, 2025 - 21:50 MST

Investigating

Microsoft Azure services continue to experience performance issues,
which may cause slow response times or intermittent errors across U-Haul systems.

To maintain operations, please continue dispatching using BackupPOS if needed.
backuppos.uhaul.net

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #


For further assistance, please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Oct 29, 2025 - 14:37 MST
This incident affected: Point of Sale (POS, UBOX), Rates and Distribution (Web AMT), and uhaul.com and Truck Share (uhaul.com).