Intermittent VOIP Phone Issues resolved

Incident Report for U-Haul System

Resolved

The intermittent issue causing dropped calls and dialing failures has been resolved. Service is operating normally, and we will continue to monitor. Thank you for your patience.
Posted Feb 16, 2026 - 08:47 MST

Monitoring

The intermittent issue causing dropped calls and dialing failures has been resolved. Service is operating normally, and we will continue to monitor. Thank you for your patience.
Posted Feb 16, 2026 - 08:38 MST

Investigating

We have reports of intermittent issues with phones dropping calls and not being able to dial out. We are currently investigating the cause for this. We will update once we know more.
Posted Feb 16, 2026 - 08:03 MST
This incident affected: VoIP (Finesse (Traffic & Contact Center)).