Resolved: ESL Server Error

Incident Report for U-Haul System

Resolved

A fix has been implemented and the ESL is now loading properly.

If you encounter any lingering effects, please refresh or close and re-open your browser.

For further assistance, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 22, 2025 - 05:32 MST

Monitoring

A fix has been implemented and the ESL is now loading properly.

If you encounter any lingering effects, please refresh or close and re-open your browser.

For further assistance, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 22, 2025 - 05:11 MST

Investigating

Centers: Please use Mobile POS to continue business operations.

Others: Please attempt in a different browser.

If issues persist, please use backupPOS - backuppos.uhaul.net

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity ##

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 22, 2025 - 04:51 MST
This incident affected: Point of Sale (ESL (Electronic Scheduling Log)).