If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Jun 23, 2025 - 05:41 MST
Monitoring
If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Jun 23, 2025 - 05:30 MST
Investigating
Workaround: Dispatch Using backup POS backuppos.uhaul.net Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
For further assistance can contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------