Meraki Admin Access

Incident Report for U-Haul System

Resolved

This has been resolved by backend updates from Cisco Meraki, all login services should be fully operational now.
Posted May 26, 2026 - 11:39 MST

Update

We are continuing to work on a fix for this issue.
Posted May 26, 2026 - 10:11 MST

Identified

There is an issue with logging into the Meraki Dashboard via SP-SAML bookmarks (uhaul.sso.meraki.com), we are coordinating with Cisco to verify what the issue is here as the default landing page behavior has changed. For now, the workaround is to use the O365 app tile to reach the dashboard. This does not impact center networking, only users' ability to access the tool for admin changes.
Posted May 26, 2026 - 10:04 MST
This incident affected: Network (Meraki (Center Networks)).