Dispatches are operational

Incident Report for U-Haul System

Resolved

Dispatches are now back up and operating normally.
The errors were caused by a file formatting issue.
Users may now use POS for normal business operations.

Any BackupPOS contracts created during the outage should now be imported.

Thank you for your patience while this issue was being resolved.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Jul 09, 2026 - 22:00 MST

Monitoring

Dispatches are now back up and operating normally.
The errors were caused by a file formatting issue.
Users may now use POS for normal business operations.

Any BackupPOS contracts created during the outage should now be imported.

BackupPOS Contracts: If you completed contracts in BackupPOS, please import those contracts into POS at this time.

Thank you for your patience while this issue was being resolved. -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Jul 09, 2026 - 21:53 MST

Investigating

All hands are working to quickly resolve the issue with dispatching rentals.
To continue business operations please use BackupPOS - backuppos.uhaul.net

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

Please wait until all systems are fully operational before importing backup contracts.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Jul 09, 2026 - 18:57 MST
This incident affected: Point of Sale (POS) and uhaul.com and Truck Share (Truck Share).