Workday login access has been restored, and users should now be able to log in normally.
If you continue to experience issues, please contact Support by calling 606901 or 800-223-6217. You can also chat using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Aug 11, 2026 - 16:04 MST
Monitoring
Workday login access has been restored, and users should now be able to log in normally.
If you continue to experience issues, please contact Support by calling 606901 or 800-223-6217. You can also chat using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Aug 11, 2026 - 15:54 MST
Investigating
Users are currently unable to log into Workday and may receive an error.
We are aware of the issue and are actively investigating. We will provide additional updates as more information becomes available.