VoIP Call Degradation Resolved

Incident Report for U-Haul System

Resolved

We’ve identified the cause of the dead air during calls, and service is back to normal.
If you encounter any lingering issues, feel free to contact VoiP support at 606905.
-------------------------------------------------------------------------------------------------
Posted Feb 27, 2026 - 10:21 MST

Monitoring

We’ve identified the cause of the dead air during calls, and service is steadily returning to normal.
If you encounter any lingering issues, feel free to contact VoiP support at 606905.
-------------------------------------------------------------------------------------------------
Posted Feb 27, 2026 - 10:11 MST

Investigating

We are currently experiencing one-way audio issues affecting call quality and normal conversation. The team is actively investigating the issue to determine the cause and scope of impact. At this time, troubleshooting is ongoing, and updates will be provided as more information becomes available.
Posted Feb 27, 2026 - 09:49 MST
This incident affected: VoIP (Finesse (Traffic & Contact Center), Center Phones).