Resolved: Dealers Unable to Complete Returns in Contract Close
Incident Report for U-Haul System
Resolved
A fix has been implemented. Please refresh and return the contract.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
----------------------------------------------------------------------------------------------------------------------------------------
Posted Dec 04, 2024 - 14:40 MST
Monitoring
A fix has been implemented. Please refresh and return the contract.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Dec 04, 2024 - 14:22 MST
Investigating
Please contact support at 1-800-223-6217, so we can assist in returning the contracts through WebBEST. You can also chat in using the life preserver icon in the bottom left corner of the ESL.

-------------------------------------------------------------------------------------------------
Posted Dec 04, 2024 - 13:49 MST
This incident affected: POS Mobile (Dashboard) (Contract Close).