The POS was down due to unexpected CPU issues. POS is back online, and our teams are continuing to monitor for any lingering effects.
If you continue to experience issues, please reach out to POS Support at VOIP extension 606901, call 1-800-223-6217, or chat via the life preserver icon in the bottom left corner of the ESL. --------------------------------------------------------------------------------------------------
Posted May 02, 2026 - 09:25 MST
Monitoring
The POS was down due to unexpected CPU issues. POS is back online, and our teams are continuing to monitor for any lingering effects.
If you continue to experience issues, please reach out to POS Support at VOIP extension 606901, call 1-800-223-6217, or chat via the life preserver icon in the bottom left corner of the ESL. --------------------------------------------------------------------------------------------------
Posted May 02, 2026 - 09:02 MST
Investigating
To continue business operations, please use BackupPOS: backuppos.uhaul.net
Centers: Log in using your SMID, last name, and entity number. Dealers: Log in using your Dealer login and entity number.
Please wait until all systems are fully operational before importing backup contracts.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------