Calls Failing for US locations - Resolved
Incident Report for U-Haul System
Resolved
Our phone provider has resolved the trouble and is reporting systems are back in service. If you are still not getting customer calls please reach out to support at 606911 option 5.
Posted Dec 03, 2024 - 09:29 MST
Identified
We have many reports of calls not working. This has been identified as a widespread issue with our phone provider and they have identified the trouble and are working on a fix.
Posted Dec 03, 2024 - 08:56 MST
This incident affected: VoIP (Finesse (Traffic & Contact Center), Center Phones).