Resolved - Uhaul.net site cannot be accessed
Incident Report for U-Haul System
Resolved
The site is back up and running.

For further assistance can contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Nov 08, 2024 - 15:34 MST
Monitoring
The site is back up and running. You may need to refresh the page.

For further assistance can contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Nov 08, 2024 - 15:23 MST
Investigating
We are working to resolve this issue.
Remain in the site if you have access.
-------------------------------------------------------------------------------------------------
Posted Nov 08, 2024 - 14:54 MST
This incident affected: uhaul.net (Tools).