Resolved - POS Slowness

Incident Report for U-Haul System

Resolved

A fix has been implemented. POS is back up and running.
Please refresh your browser or press "F5".

If you encounter any lingering issues feel free to contact support at either 606901, 800-223-6217,
or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
------------------------------------------------------------------------------------------------
Posted Apr 14, 2025 - 08:49 MST

Monitoring

A fix has been implemented. POS is back up and running.
Please refresh your browser or press "F5".

If you encounter any lingering issues feel free to contact support at either 606901, 800-223-6217,
or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
------------------------------------------------------------------------------------------------
Posted Apr 14, 2025 - 08:37 MST

Update

A fix has been implemented. POS is back up and running.
Please refresh your browser or press "F5".

If you encounter any lingering issues feel free to contact support at either 606901, 800-223-6217,
or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
------------------------------------------------------------------------------------------------
Posted Apr 14, 2025 - 08:36 MST

Investigating

To continue business operations use backupPOS.
backuppos.uhaul.net

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Apr 14, 2025 - 08:14 MST
This incident affected: Point of Sale (POS).