Dealer Network Restored

Incident Report for U-Haul System

Resolved

The issue affecting the Dealer Network has been resolved, and services have returned to normal.

Dealers may resume normal business operations.
If BackupPOS was used during the outage, please import any BackupPOS contracts.

If you continue to experience issues or need assistance importing BackupPOS contracts,
please contact Support 800-223-6217, or chat with us by selecting the Life Preserver icon in the bottom-left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jul 17, 2026 - 13:10 MST

Monitoring

The issue affecting the Dealer Network has been resolved, and services have returned to normal.

Dealers may resume normal business operations.
If BackupPOS was used during the outage, please import any BackupPOS contracts.

If you continue to experience issues or need assistance importing BackupPOS contracts,
please contact Support 800-223-6217, or chat with us by selecting the Life Preserver icon in the bottom-left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jul 17, 2026 - 13:02 MST

Update

We are currently investigating an issue causing Dealer Network slowness and intermittent availability.
Our teams are actively working to restore normal service as quickly as possible.

To continue business operations, please use BackupPOS - backuppos.uhaul.net

Dealers: Login with your Dealer login and your Entity #
Please wait until all systems are fully operational before importing backup contracts.

For further assistance please contact support at 800-223-6217.
--------------------------------------------------------------------------------------------------
Posted Jul 17, 2026 - 12:51 MST

Investigating

We are looking into the cause to get the site back online.
To continue business operations, please use BackupPOS - backuppos.uhaul.net

Dealers: Login with your Dealer login and your Entity #
Please wait until all systems are fully operational before importing backup contracts.

For further assistance please contact support at 800-223-6217.
--------------------------------------------------------------------------------------------------
Posted Jul 17, 2026 - 12:37 MST
This incident affected: Dealer Network (uhauldealer.com).