WebSelfStorage Sign-In Issues Restored

Incident Report for U-Haul System

Resolved

Users should now be able to sign in and access WebSelfStorage normally.

Thank you for your patience while this matter was resolved.
-------------------------------------------------------------------------------------------------
Posted Aug 23, 2026 - 12:54 MST

Monitoring

Users should now be able to sign in and access WebSelfStorage normally.

Thank you for your patience while this matter was resolved.
-------------------------------------------------------------------------------------------------
Posted Aug 23, 2026 - 12:42 MST

Investigating

We are aware that the WebSelfStorage sign-in issue has returned and users may once again receive an error when attempting to sign in.

We are actively investigating the issue and will provide additional updates as more information becomes available.
-------------------------------------------------------------------------------------------------
Posted Aug 23, 2026 - 12:27 MST

Monitoring

Users should now be able to sign in and access WebSelfStorage normally.

Thank you for your patience while this matter was resolved.
-------------------------------------------------------------------------------------------------
Posted Aug 23, 2026 - 12:15 MST

Investigating

We are currently investigating reports of users receiving an error when attempting to sign in to WebSelfStorage.

We will provide additional updates as more information becomes available.
-------------------------------------------------------------------------------------------------
Posted Aug 23, 2026 - 12:04 MST
This incident affected: WebSelfStorage.