Uhaul.net Reports are back online

Incident Report for U-Haul System

Resolved

The Uhaul.net Reports are back online. Refresh the page to gain access.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted May 13, 2026 - 11:15 MST

Monitoring

The Uhaul.net Reports are back online. Refresh the page to gain access.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted May 13, 2026 - 10:59 MST

Investigating

The reports page is down, and our teams are in the process of restoring service.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted May 13, 2026 - 10:04 MST
This incident affected: uhaul.net (Reports).