For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Mar 27, 2025 - 14:10 MST
Monitoring
A fix is in place. Please refresh your browser.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Mar 27, 2025 - 13:54 MST
Update
Use backupPOS to continue business operations - backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Mar 27, 2025 - 13:08 MST
Update
Use backupPOS to continue business operations - backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Mar 27, 2025 - 12:57 MST
Investigating
Centers: Please close your browser, then re-open it.
Other: Please try clearing your browsing data.
Steps to clear browsing data: - Press and hold CTRL+Shift+Delete. - Go to the 'Advanced' tab. - Set the time range to 'All Time.' - Only select Browsing history, Download history, and Cached Images and files - Click on 'Clear Data.'
If issues continue to persist, please use backupPOS to continue business operations - backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Mar 27, 2025 - 11:12 MST
This incident affected: Point of Sale (POS, ESL (Electronic Scheduling Log)), Rates and Distribution (Web AMT), and uhaul.com and Truck Share (uhaul.com).