If you encounter any lingering issues, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Jan 06, 2026 - 13:08 MST
Monitoring
If you encounter any lingering issues, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Jan 06, 2026 - 12:56 MST
Investigating
The Buyer's Club is currently unavailable. The team is actively working to resolve the issue and restore service as quickly as possible.
For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. --------------------------------------------------------------------------------------------------
Posted Jan 06, 2026 - 12:27 MST
This incident affected: Dealer Network (uhauldealer.com).