The issue was caused by a third-party network provider routing traffic inefficiently before it reached U-Haul's systems, resulting in slower response times for some locations. Changes have been implemented to improve traffic routing and restore normal performance. We will continue working with our network providers to address the underlying routing issue and help prevent similar occurrences.
If you continue to experience issues, please contact Support by calling 606901 or 800-223-6217. You can also chat using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Jul 26, 2026 - 09:08 MST
Monitoring
The issue was caused by a third-party network provider routing traffic inefficiently before it reached U-Haul's systems, resulting in slower response times for some locations. Changes have been implemented to improve traffic routing and restore normal performance. We will continue working with our network providers to address the underlying routing issue and help prevent similar occurrences.
If you continue to experience issues, please contact Support by calling 606901 or 800-223-6217. You can also chat using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Jul 26, 2026 - 08:58 MST
Investigating
We are investigating reports of POS slowness from some locations in the Southeast (FL, GA, AL, NC, TN).
To continue business operations in backupPOS - backuppos.uhaul.net Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
Please do not upload Backup contracts until the system is fully operational.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------