Finesse not available
Incident Report for U-Haul System
Resolved
Finesse is working again. If you are still seeing an error, please reach out to the voip team at 606905.
Posted Nov 07, 2024 - 05:22 MST
Investigating
Traffic locations are reporting Finesse is down with an "out of service" message. The voice team is working to resolve this as quickly as possible.
Posted Nov 07, 2024 - 05:09 MST
This incident affected: VoIP (Finesse (Traffic & Contact Center)).