Resolved - Unable to initiate Live support chat
Incident Report for U-Haul System
Resolved
Live chat support through the POS console is back online.

If you encounter any lingering issues, feel free to contact support at either extension 606901 or call 1800-223-6217.
-------------------------------------------------------------------------------------------------
Posted Sep 23, 2024 - 14:03 MST
Monitoring
Live chat support through the POS console is back online.

If you encounter any lingering issues, feel free to contact support at either extension 606901 or call 1800-223-6217.
-------------------------------------------------------------------------------------------------
Posted Sep 23, 2024 - 13:47 MST
Update
Live chat support through the POS console is currently unavailable due to the plugin with our chat vendor failing to load correctly.

The chat function for U-Box Mobile and AMT are working but an initial message must be sent to activate the prompts to reach a live agent.

For Live assistance you can continue to reach the support teams by calling:
POS Support: 606901 or 1-800-223-6217
U-Box Support: 555100 or 1-602-760-4927
Posted Sep 21, 2024 - 10:09 MST
Update
Live chat support through the POS console is currently unavailable due to the plugin with our chat vendor failing to load correctly.

The chat function for U-Box Mobile and AMT are working but an initial message must be sent to activate the prompts to reach a live agent.

For Live assistance you can continue to reach the support teams by calling:
POS Support: 606901 or 1-800-223-6217
U-Box Support: 555100 or 1-602-760-4927
Posted Sep 21, 2024 - 09:24 MST
Investigating
Live chat support through the POS console is currently unavailable due to the plugin with our chat vendor failing to load correctly.

The chat function for U-Box Mobile and AMT are working but an initial message must be sent to activate the prompts to reach a live agent.

For Live assistance you can continue to reach the support teams by calling:
POS Support: 606901 or 1-800-223-6217
U-Box Support: 555100 or 1-602-760-4927
Posted Sep 20, 2024 - 19:00 MST
This incident affected: Rates and Distribution (Web AMT) and Point of Sale (POS Console, UBOX).