Dealer Network Sign-in is Fully Restored

Incident Report for U-Haul System

Resolved

If you encounter any lingering issues, please contact support at 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 31, 2026 - 13:54 MST

Monitoring

If you encounter any lingering issues, please contact support at 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 31, 2026 - 13:44 MST

Update

As a workaround, please sign-in directly into POS - pos.uhaul.net

To sign-in: Enter your Dealer Network Username and Password.

For further assistance, please reach out to support by calling 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 31, 2026 - 13:20 MST

Investigating

To continue business operations please use BackupPOS - backuppos.uhaul.net

Dealers: Login with your Dealer login and your Entity #

Please Do not upload BackupPOS Contracts until the System is Fully Restored.

For further assistance, please reach out to support by calling 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 31, 2026 - 13:09 MST
This incident affected: Dealer Network (uhauldealer.com).