WebAMT and Coverages are now Restored

Incident Report for U-Haul System

Resolved

The issues affecting WebAMT reservations and One-Way coverage rates have been resolved.

The issue was caused by an unintended release.
The release has been addressed, and users should now be able to open reservations in WebAMT and see One-Way coverage rates as expected.

Please import any BackupPOS contracts created during the incident at this time.

If you continue to experience any problems, please reach out to Support by calling 606901 or 800-223-6217. You can also chat with Support using the life preserver icon in the bottom-left corner of the ESL
-------------------------------------------------------------------------------------------------
Posted Sep 25, 2026 - 10:09 MST

Monitoring

The issues affecting WebAMT reservations and One-Way coverage rates have cleared.
Users should now be able to open reservations in WebAMT, and One-Way coverage rates should display as expected.


Please import any BackupPOS contracts created during the incident at this time.

If you continue to experience any problems, please reach out to Support by calling 606901 or 800-223-6217. You can also chat with Support using the life preserver icon in the bottom-left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Sep 25, 2026 - 09:56 MST

Update

We are currently investigating multiple issues in WebAMT.
Some users are reporting:
- Being unable to open reservations in WebAMT.
- One-Way coverage rates displaying incorrectly, including rates that may appear higher or lower than expected.


Workaround:
Please use BackupPOS when creating One-Way reservations while this issue is being investigated.

backuppos.uhaul.net

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

Please do not upload Backup contracts until the system is fully operational.

For further assistance, please reach out to Support by calling 606901 or 800-223-6217. You can also chat with Support using the life preserver icon in the bottom-left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Sep 25, 2026 - 09:35 MST

Update

We are currently investigating multiple issues in WebAMT.
Some users are reporting:
- Being unable to open reservations in WebAMT.
- Coverage rates not displaying or being unable to add coverage to One-Way contracts.


Workaround:
Please use BackupPOS when creating One-Way reservations while this issue is being investigated.

backuppos.uhaul.net

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

Please do not upload Backup contracts until the system is fully operational.

For further assistance, please reach out to Support by calling 606901 or 800-223-6217. You can also chat with Support using the life preserver icon in the bottom-left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Sep 25, 2026 - 09:16 MST

Investigating

We are currently investigating reports of being unable to open reservations in WebAMT.

For further assistance, please reach out to Support by calling 606901 or 800-223-6217. You can also chat with Support using the life preserver icon in the bottom-left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Sep 25, 2026 - 08:54 MST
This incident affected: Point of Sale (POS) and Rates and Distribution (Web AMT).