For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Apr 01, 2025 - 13:08 MST
Update
A fix is in place. Please refresh your browser.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Apr 01, 2025 - 12:55 MST
Monitoring
A fix is in place. Please refresh your browser.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Apr 01, 2025 - 12:54 MST
Investigating
To continue business operations use backupPOS. backuppos.uhaul.net Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Apr 01, 2025 - 12:41 MST
This incident affected: Point of Sale (POS) and Rates and Distribution (Web AMT).