Cross Contact Is Fully Operational

Incident Report for U-Haul System

Resolved

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Dec 14, 2025 - 07:31 MST

Monitoring

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Dec 14, 2025 - 07:21 MST

Update

Our teams are actively working to restore service.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Dec 13, 2025 - 16:10 MST

Update

Dealer Network: Dealers are now able to sign into Dealer Network and access POS successfully.

Cross Contact: Our teams are actively working to restore service.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Dec 13, 2025 - 13:49 MST

Update

Dealer Network: As a workaround, Dealers please sign-in directly into POS - pos.uhaul.net

To sign-in: Enter your Dealer Network Username and Dealer Network Password.

Cross Contact: Our teams are actively working to restore service.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Dec 13, 2025 - 08:57 MST

Update

As a workaround, Dealers please sign-in directly into POS - pos.uhaul.net

To sign-in: Enter your Dealer Network Username and Dealer Network Password.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Dec 13, 2025 - 07:33 MST

Update

As a workaround, Dealers please sign-in directly into POS - pos.uhaul.net

To sign-in: Enter your Dealer Network Username and Dealer Network Password.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Dec 13, 2025 - 07:22 MST

Update

To continue business operations, please dispatch using backup POS - backuppos.uhaul.net

Dealers: Login with your Dealer login and your Entity #

Please Do Not Upload BackupPOS Contracts Until the System is Fully Restored.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Dec 13, 2025 - 06:53 MST

Investigating

To continue business operations, please dispatch using backup POS - backuppos.uhaul.net

Dealers: Login with your Dealer login and your Entity #

Please Do Not Upload BackupPOS Contracts Until the System is Fully Restored.

For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Dec 13, 2025 - 05:38 MST
This incident affected: uhaul.net (Cross Contact).