Resolved: Users are not receiving SMS and Email Verification Messages
Incident Report for U-Haul System
Resolved
A fix has been implemented, and receiving verification codes is back up and running.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jan 23, 2025 - 05:22 MST
Monitoring
A fix has been implemented, and receiving verification codes is back up and running.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jan 23, 2025 - 05:11 MST
Investigating
We are experiencing issues receiving with SMS and Email Verification messages.

We are currently investigating this problem and will provide further updates when available. For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jan 22, 2025 - 14:44 MST
This incident affected: Point of Sale (POS) and Email/O365 applications (Email).