O365 services restored

Incident Report for U-Haul System

Resolved

Any lingering issues, please contact support at VOIP extension 606901, call us at 800-223-6217.
--------------------------------------------------------------------------------------------------
Posted Oct 29, 2025 - 21:53 MST

Update

Any lingering issues, please contact support at VOIP extension 606901, call us at 800-223-6217.
--------------------------------------------------------------------------------------------------
Posted Oct 29, 2025 - 21:52 MST

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 17:10 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 17:09 MST

Identified

Microsoft has identified this as a DNS issue and is in the process of resolving it.
Posted Oct 29, 2025 - 09:53 MST
This incident affected: Email/O365 applications (Email, Office 365 Online Apps).