Please move back to normal POS to continue business operations.
If you completed transactions in BackupPOS, please import those contracts into POS to complete processing.
There was a communication issue between systems leading the POS to respond slowly, and we are investigating the root cause.
We are very sorry for the horrendous problems seen again today.
If you encounter any lingering issues, feel free to contact support at 606901, 800-223-6217, or initiate a chat by clicking the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted May 30, 2026 - 11:56 MST
Monitoring
Please move back to normal POS to continue business operations.
If you completed transactions in BackupPOS, please import those contracts into POS to complete processing.
There was a communication issue between systems leading the POS to respond slowly, and we are investigating the root cause.
We are very sorry for the horrendous problems seen again today.
If you encounter any lingering issues, feel free to contact support at 606901, 800-223-6217, or initiate a chat by clicking the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted May 30, 2026 - 11:41 MST
Update
We have all hands on deck and are actively working to resolve the issue.
If issues continue to persist, please use BackupPOS: backuppos.uhaul.net
Centers: Log in using your SMID, last name, and entity number. Dealers: Log in using your Dealer login and entity number.
Please wait until all systems are fully operational before importing backup contracts.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted May 30, 2026 - 08:23 MST
Investigating
To continue business operations, please use BackupPOS: backuppos.uhaul.net
Centers: Log in using your SMID, last name, and entity number. Dealers: Log in using your Dealer login and entity number.
Please wait until all systems are fully operational before importing backup contracts.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------