U-Haul Applications are Fully Operational

Incident Report for U-Haul System

Resolved

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 07, 2026 - 10:30 MST

Monitoring

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 07, 2026 - 10:19 MST

Update

There is a global DNS issue that is impacting a small number of locations. These locations may be unable to access U-haul sites like POS, uhaul.net, Uhaul.com and uhauldealer.com.

If you are unable to reach these sites, you can try changing the DNS on your PC to another provider. (1.1.1.1)

The link below has instructions that may be helpful.

https://m.youtube.com/watch?v=uozLlP3bLbs&pp=ygUoQ2hhbmdlIGRlZmF1bHQgZG5zIHdpbmRvd3MgdG8gY2xvdWRmbGFyZQ%3D%3D

We do not have an ETA for a resolution but will continue to monitor and post updates as we have them.
Posted Mar 07, 2026 - 09:28 MST

Investigating

We have all hands-on deck working to resolve the issue.

To continue business operations in backupPOS - backuppos.uhaul.net

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

Please Do not upload BackupPOS Contracts until the System is Fully Restored.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 07, 2026 - 07:43 MST
This incident affected: Point of Sale (POS), Dealer Network (uhauldealer.com), uhaul.com and Truck Share (uhaul.com), and uhaul.net (Tools).