Resolved - Workday / U-Haul life

Incident Report for U-Haul System

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 13:33 MST

Monitoring

Workday / U-Haul life is now back online.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 17, 2025 - 13:16 MST

Investigating

The Workday/UhaulLife Site is currently down due to an issue on the web provider's end. We will update you when we have further details.

-------------------------------------------------------------------------------------------------
Posted Mar 17, 2025 - 11:57 MST
This incident affected: Workday / U-Haul life.