A fix has been implemented and Uhaul.net is back up and running.
If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Dec 09, 2024 - 10:01 MST
Monitoring
A fix has been implemented and Uhaul.net is back up and running.
If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Dec 09, 2024 - 09:50 MST
Investigating
We have all hands-on deck looking into this matter.
For further assistance can contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Dec 09, 2024 - 09:21 MST
This incident affected: uhaul.net (Cross Contact).