POS is now back up and operating normally - please resume business operations in normal POS.
If you completed any transactions in BackupPOS, please import those contracts now.
Our teams are continuing to investigate the root cause of the issue.
If you experience any lingering issues, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Jun 27, 2026 - 08:39 MST
Monitoring
POS is now back up and operating normally - please resume business operations in normal POS.
If you completed any transactions in BackupPOS, please import those contracts now.
Our teams are continuing to investigate the root cause of the issue.
If you experience any lingering issues, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Jun 27, 2026 - 08:28 MST
Update
If you are continuing to experience POS slowness, please clear your browsing data.
Steps to clear browsing data: - Press and hold CTRL+Shift+Delete. - Go to the 'Advanced' tab. - Set the time range to 'All Time.' - Only select Browsing history, Download history, and Cached Images and files - Click on 'Clear Data.'
If issues continue to persist, please continue business operations in backupPOS - backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
Please do not upload Backup contracts until the system is fully operational.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Jun 27, 2026 - 07:50 MST
Investigating
Centers: Close and re-open browser Other: Clear browsing data
Steps to clear browsing data: - Press and hold CTRL+Shift+Delete. - Go to the 'Advanced' tab. - Set the time range to 'All Time.' - Only select Browsing history, Download history, and Cached Images and files - Click on 'Clear Data.'
If issues continue to persist, please continue business operations in backupPOS - backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
Please do not upload Backup contracts until the system is fully operational.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------