If you encounter any lingering issues, please contact support at 606901, 800-223-6217, or initiate a chat by clicking the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Nov 18, 2025 - 07:58 MST
Monitoring
If you encounter any lingering issues, please contact support at 606901, 800-223-6217, or initiate a chat by clicking the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Nov 18, 2025 - 07:47 MST
Investigating
For Live assistance you can continue to reach the support teams by calling: POS Support: 606901 or 1-800-223-6217 U-Box Support: 555100 or 1-602-760-4927 -------------------------------------------------------------------------------------------------
Posted Nov 18, 2025 - 07:00 MST
This incident affected: Point of Sale (POS Console).