A fix has been implemented and all applications are now running properly.
If issues continue to persist, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Nov 04, 2025 - 06:21 MST
Monitoring
A fix has been implemented and all applications are now running properly.
If issues continue to persist, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Nov 04, 2025 - 06:11 MST
Investigating
We have all hands-on deck working to resolve the issue.
For further assistance, please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Nov 04, 2025 - 06:04 MST
This incident affected: Point of Sale (Showroom Sales, WebBEST).