The errors are cleared and the Showroom Sales is loading.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted May 06, 2025 - 11:38 MST
Monitoring
The errors are cleared and the Showroom Sales is loading.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted May 06, 2025 - 11:23 MST
Investigating
Please use BackupPOS - backuppos.uhaul.net
Centers: Login With Your SMID, Last name and Entity # Dealers: Login with your Dealer login and your Entity #
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted May 06, 2025 - 11:01 MST
This incident affected: Point of Sale (Showroom Sales).