Resolved: POS Slowness
Incident Report for U-Haul System
Resolved
A fix has been implemented and the POS is now working properly.

If you are still experiencing an issue, please contact POS support at VOIP ext 606911, 800-223-6217 or via live chat by selecting the life preserver located in the lower left of the ESL.

-------------------------------------------------------------------------------------------------
Posted Oct 08, 2024 - 12:01 MST
Monitoring
A fix has been implemented and the POS is now working properly.

If you are still experiencing an issue, please contact POS support at VOIP ext 606911, 800-223-6217 or via live chat by selecting the life preserver located in the lower left of the ESL.

-------------------------------------------------------------------------------------------------
Posted Oct 08, 2024 - 11:49 MST
Investigating
To continue business operations, dispatch Using backup POS - backuppos.uhaul.net

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

For further assistance can contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Posted Oct 08, 2024 - 11:18 MST
This incident affected: Point of Sale (POS).