There has been a fix made, POS is back up and running.
If you encounter any more issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Feb 04, 2025 - 11:47 MST
Monitoring
There has been a fix made, POS is back up and running.
If you encounter any more issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Feb 04, 2025 - 11:32 MST
Investigating
To continue business operations, please use backupPOS - backuppos.uhaul.net
Reminder To Log-In:
Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.