Receipts are now generating properly

Incident Report for U-Haul System

Resolved

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jul 03, 2025 - 07:41 MST

Monitoring

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jul 03, 2025 - 07:23 MST

Investigating

Centers: Please view the receipts in Uhaul.net

Uhaul.net > Equipment > Search contract number > Open contract > Receipts for this contract

Dealers: Please view the receipts in Dealer Network

Dealer Network > Equipment > Search contract number > Open contract > Receipts for this contract

Other:

WebBEST >Reporting > Contract Search and Reprint > Find or Search contract number

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jul 03, 2025 - 06:26 MST
This incident affected: Point of Sale (POS).