Web AMT Restored

Incident Report for U-Haul System

Resolved

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 16:40 MST

Monitoring

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 16:28 MST

Investigating

We have all hands on deck looking into this matter.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 15:21 MST
This incident affected: Rates and Distribution (Web AMT).