Hookup Book Functionality Restored

Incident Report for U-Haul System

Resolved

The Hookup Book is now back up and working as expected

For lingering issues, please reach out to POS Support at VOIP extension 606901, call 1-800-223-6217, or chat via the life preserver icon in the bottom left corner of the ESL.
Posted Mar 24, 2026 - 11:21 MST

Update

The Hookup Book is now back up and working as expected

For lingering issues, please reach out to POS Support at VOIP extension 606901, call 1-800-223-6217, or chat via the life preserver icon in the bottom left corner of the ESL.
Posted Mar 24, 2026 - 11:06 MST

Investigating

Workaround: use backuppos.uhaul.net to create/dispatch Trailer reservations

Reminder: To Log-in
Centers: Smid, Lastname and Center #
Dealers: Username and Dealer #

The team is working is working on getting the hookup book back up and running again.

For further assistance, please reach out to our support team at VOIP extension 606901, call 800-223-6217, or chat via the life preserver icon in the bottom left corner of the ESL.
--------------------------------------------------------------------------------------------------
Posted Mar 24, 2026 - 10:46 MST
This incident affected: Point of Sale (POS).