Accounts Payable is Restored

Incident Report for U-Haul System

Resolved

The Accounts Payable issue has been resolved, and users should now be able to view their Vendors and Local purchase orders successfully.

If you continue to experience issues or need assistance, please contact Support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom-left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Sep 02, 2026 - 08:18 MST

Monitoring

The Accounts Payable issue has been resolved, and users should now be able to view their Vendors and Local purchase orders successfully.

If you continue to experience issues or need assistance, please contact Support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom-left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Sep 02, 2026 - 08:08 MST

Update

We are currently investigating reports of users being unable to view their Vendors and Local purchase orders within Accounts Payable in Uhaul.net.

We will provide additional updates as more information becomes available.
------------------------------------------------------------------------------------------------
Posted Sep 02, 2026 - 07:17 MST

Investigating

We are currently investigating reports of users being unable to view their Vendors and Local purchase orders within Accounts Payable in Uhaul.net.

We will provide additional updates as more information becomes available.
-------------------------------------------------------------------------------------------------
Posted Sep 02, 2026 - 07:15 MST
This incident affected: uhaul.com and Truck Share (uhaul.com) and uhaul.net (Accounts Payable).