The WebSelfStorage sign-in issue has been addressed, and users should now be able to sign in normally.
If you continue to experience issues, please contact Support by calling 672059 or 877-626-4455. Thank you for your patience while this issue was corrected. -------------------------------------------------------------------------------------------------
Posted Aug 14, 2026 - 08:08 MST
Monitoring
The WebSelfStorage sign-in issue has been addressed, and users should now be able to sign in normally.
If you continue to experience issues, please contact Support by calling 672059 or 877-626-4455. Thank you for your patience while this issue was corrected. -------------------------------------------------------------------------------------------------
Posted Aug 14, 2026 - 08:07 MST
Investigating
We are currently investigating reports of users experiencing issues signing in to WebSelfStorage. Users experiencing issues signing in to WebSelfStorage can first sign in through uhaul.net, then return to WebSelfStorage.
For further assistance, you can contact support by calling 672059 or 877-626-4455. -------------------------------------------------------------------------------------------------